Expanded NGSS-aligned curriculum and new Artificial Intelligence curriculum coming soon! Learn more.

Please note our Tech and Age Guidelines:

  • Camp:ASPIRE courses are recommended for children 8 years old and up.
  • The UKIT app is required for all courses. It is compatible with iOS, Android, and Chromebook and must meet these minimum system requirements: Apple iOS 10.0 or higher, Android 5.0 or higher, Chromebook Chrome OS Version 53 or later.

Enroll Now

 

Thank you!

We’ve received your message and will be in touch shortly.

Check out our free app on the App Store!